MetaCase Homepage
Forum Home Forum Home > > MetaEdit+
  New Posts New Posts RSS Feed - Metaedit+ project does not open
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Metaedit+ project does not open

 Post Reply Post Reply
Author
Message
mert View Drop Down
Contributor
Contributor


Joined: 16.Mar.2016
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote mert Quote  Post ReplyReply Direct Link To This Post Topic: Metaedit+ project does not open
    Posted: 09.Sep.2020 at 20:24
Hello,

We work collabroatively with my PhD student, who edit the metamodel and share the corresponding Metaedit+ project folder with me. So, I am expected to open the meta-model. However, when I try to open the Metaedit+ project folder that my PhD student sent, I got the following error message. 

Image and database versions do not match. Image is 5.1 and database is 5.5. You will now be logged out.

Can you please help me on avoiding the error here ?
Back to Top
mert View Drop Down
Contributor
Contributor


Joined: 16.Mar.2016
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote mert Quote  Post ReplyReply Direct Link To This Post Posted: 12.Sep.2020 at 13:02
Hello,

As far as I see, no MAC OS supported form of version 5.5 has been released. Also, another issue is tat any meta-model defined with the version 5.5 cannot be opened and edited via the version 5.1. 

Are those claims correct ? If not, can you please clarify us on that? 

Best
Back to Top
stevek View Drop Down
MetaCase
MetaCase
Avatar

Joined: 11.Mar.2008
Points: 581
Post Options Post Options   Thanks (0) Thanks(0)   Quote stevek Quote  Post ReplyReply Direct Link To This Post Posted: 15.Sep.2020 at 14:28
I see we've already answered these questions, which were also sent by email by you and your student. I'll post the answers here for others:

You should be able to transfer most information from 5.5 to 5.1. The 5.5 user can export in the MetaEdit+ XML formats (.MXT for exporting metamodels, .MXM for exporting models), and the 5.1 user can create a new repository and project and import them (MXT then MXM). Obviously this will not make 5.1 able to use the parts concerning features added in 5.5, but generally the results are still useful.

Another approach is to export the models from 5.5 as binary patches (.MEC for models and their metamodels, .MET for any other metamodels you want to send). The other person can then download the evaluation version of MetaEdit+ 5.5 on Windows, create a new repository and project, and import those files.

If the metamodel contains symbols with templates that use library symbols, export those library symbols as .MXS and import them as for the other XML files.

Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 10.16
Copyright ©2001-2013 Web Wiz Ltd.

This page was generated in 0.094 seconds.